f13.net

f13.net General Forums => Titan Quest => Topic started by: Strazos on July 12, 2006, 11:14:34 AM



Title: Graphical Problems
Post by: Strazos on July 12, 2006, 11:14:34 AM
Anyone else having some odd...graphical glitches?

I was just going through Egypt, when suddenly I start to run into areas where these black splotches start to obscure the center of the screen...sometimes just a little, sometimes almost the entire play area. Oddly, I can still move and attack and stuch, and item labels will still show up in the obscured area...but it's Really annoying. It sure is hard to play blind.


Title: Re: Graphical Problems
Post by: Engels on July 12, 2006, 11:18:30 AM
You either have a corrupt install or a failing video card. Is it always the same exact areas that are blotchy, or does it seem random? For starters, I'd turn down your quality settings to see if that makes a difference. TQ seems to be very video intensive; at first you think its just the usual isometric Diablo style graphics which shouldn't punish your card very much, until you realise that you can zoom in on the graphics to a near FPS level of detail. Compound that with water and shadow effects.


Title: Re: Graphical Problems
Post by: Strazos on July 12, 2006, 11:28:37 AM
Seems to be the same areas....I can walk a bit further and get out of the "black hole' area...but if I turn around I can walk right back into the area. It only seems to occur in a few of the desert Egypt maps...


Title: Re: Graphical Problems
Post by: Nija on July 12, 2006, 11:40:34 AM
I had an instance where I couldn't enter a cave because the "stairs down" stuff wasn't loading - it just looked like a flat, see through polygon. I portaled to town and back and it was fixed.

Your issue might be close to the same, but I'd try forcing vertical sync in your video card options just in case it has something to do with that.


Title: Re: Graphical Problems
Post by: Strazos on July 12, 2006, 12:29:37 PM
Nope, I tried messing with all the settings except for res.

Also, sometimes....and this is only in Egypt again, but some of the ground will become see-through...kind of annoying. Hopefully it will pass.


Title: Re: Graphical Problems
Post by: Morfiend on July 12, 2006, 12:47:51 PM
The game has some serious graphic issues some time.

I had this thing where in one of the caves, the transparancy got messed up, and when i walked behind a certen wall, it wouldnt go transparant, and I dropped to about .2 FPS until I could get out from behind the wall.

Another time, I was in the open and all of a sudded I dropped to about 1 frame every 5 seconds, and right at the edge of my screan a texture was messing up. as I slowly slowly got closer, it was a monster I think but its graphics where very messed up, and it looked like a huge spiked ball of textures shooting off in every direction.

Those where the two main problems I had. Alos, my friend I play with gets corrupt graphics in certen towns, and also when he teleports to town some time. He can fix it by droping another telepad, and taking it to a different town and then coming back.


Title: Re: Graphical Problems
Post by: Zetleft on July 13, 2006, 01:05:42 PM
I had the same glitches for awhile as well.  Basically the whole spamp area in the first chapter was a black hole for me.  Uninstalling my ati drivers and getting latest ones from omega fixed me right up.  Also lowered details on reflection and shadows but that was mostly due to having alot of slowdown.... I fear my first multiplayer game. 


Title: Re: Graphical Problems
Post by: Strazos on July 13, 2006, 03:32:16 PM
Hmmm, I guess I'll try updating my omega drivers....

But I remember reading the odd update procedures, and they scared me off; Don't fix what's not broken, and all that.

EDIT: The OmegaDrivers guy has really improved his installation processes - updating was simple, and now Titan Quest runs like a dream again.