f13.net

f13.net General Forums => RIFT => Topic started by: schild on February 26, 2011, 06:01:18 PM



Title: Sigh. Preorder code not working.
Post by: schild on February 26, 2011, 06:01:18 PM
Finally got my preorder code, here's what it says:

    * We are unable to redeem your voucher at this time. Please try again later.


Title: Re: Sigh. Preorder code not working.
Post by: Rendakor on February 26, 2011, 06:06:00 PM
Where'd you preorder? Is it just not taking the code at all, or did it take the code and give you some but not all of the stuff?

I ask because I preordered at Gamestop and got a code that gives me Head Start access, but no mount until (presumably) I use the code inside the box.


Title: Re: Sigh. Preorder code not working.
Post by: schild on February 26, 2011, 06:18:33 PM
From Fry's. The thing says I should be able to join the headstart. I don't know what's going on. So bored.


Title: Re: Sigh. Preorder code not working.
Post by: ghost on February 26, 2011, 06:32:11 PM
That sucks, man.  Well, take solace.  The game is no fun at all, and will continue to be absolutely no fun until the official release date.   :wink:


Title: Re: Sigh. Preorder code not working.
Post by: Hayduke on February 26, 2011, 08:50:41 PM
Where'd you preorder? Is it just not taking the code at all, or did it take the code and give you some but not all of the stuff?

I ask because I preordered at Gamestop and got a code that gives me Head Start access, but no mount until (presumably) I use the code inside the box.


I thought everyone got the mounts in head start and it's not till release that you have to actually verify it.  Did you check your mailbox?


Title: Re: Sigh. Preorder code not working.
Post by: Rendakor on February 26, 2011, 09:18:49 PM
Only like 50 times. I got the pet, and the rune thing, but no mount. Several other people in chat who preordered from B&M stores reported the same issue, so I'm assuming it'll be fixed when the game launches. I said fuck it and just bought a mount.


Title: Re: Sigh. Preorder code not working.
Post by: EWSpider on February 26, 2011, 11:57:10 PM
Only like 50 times. I got the pet, and the rune thing, but no mount. Several other people in chat who preordered from B&M stores reported the same issue, so I'm assuming it'll be fixed when the game launches. I said fuck it and just bought a mount.

Did you order the Collector's or Standard Edition?


Title: Re: Sigh. Preorder code not working.
Post by: schild on February 27, 2011, 12:29:59 AM
No mount or pet here.


Title: Re: Sigh. Preorder code not working.
Post by: Rendakor on February 27, 2011, 01:04:26 AM
I ordered the collectors.

Edit: And as I log in just now, I find a turtle mount in my mailbox. Fuck, wish I hadn't blown that 2p on the zebra thing. Wonder if they'll give it back if I petition it.


Title: Re: Sigh. Preorder code not working.
Post by: Nebu on February 27, 2011, 11:19:39 AM
I ordered the collectors.

Edit: And as I log in just now, I find a turtle mount in my mailbox. Fuck, wish I hadn't blown that 2p on the zebra thing. Wonder if they'll give it back if I petition it.

I wouldn't worry about 2p.  I've blown more than that on heals and respecs.  Money starts coming pretty fast in the 20's and 30's.


Title: Re: Sigh. Preorder code not working.
Post by: Lakov_Sanite on February 27, 2011, 10:16:43 PM
And seriously, fuck the turtle mount it's ugly as hell and everyone has one.


Title: Re: Sigh. Preorder code not working.
Post by: Threash on February 27, 2011, 10:22:58 PM
Everyone has one because the only people playing atm are the ones who pre ordered :P


Title: Re: Sigh. Preorder code not working.
Post by: Sobelius on February 28, 2011, 09:39:37 AM
And seriously, fuck the turtle mount it's ugly as hell and everyone has one.

Yep -- first thing i did when I had the plat was get a different looking mount. Purely vanity on my part, but worth it.


Title: Re: Sigh. Preorder code not working.
Post by: Bzalthek on February 28, 2011, 10:11:28 AM
{img]penguin: "I just gotte be me!"[/img]